Back to overview
Downtime
BYOD Server down
Apr 25, 2026 at 10:33pm UTC
Affected services
BYOD #1 Server
Resolved
Apr 27, 2026 at 3:20am UTC
We have figured out what the issue was, the BYOD server should be back up and normal and all BYOD links should be working, thank you all for your patience!
Affected services
Created
Apr 25, 2026 at 10:33pm UTC
BYOD Server is down, we are currently investigating the issue and the cause and will try to get it back up as soon as possible!
Affected services