Back to overview
Degraded
Nexora Mirror is buggy
Apr 23, 2026 at 6:38pm UTC
Affected services
Nexora - Main Site
Resolved
Apr 24, 2026 at 4:18am UTC
We have figured out that there was an error with AWS configuration, we requested a higher limit for requests (which AWS accepted) so now everything should be back to normal.
Affected services
Created
Apr 23, 2026 at 6:38pm UTC
A large percentage of our users are experiencing issues with firebase domains and link finder, it is giving errors such as "rate limit exceeded" and more, we are currently investigating the issue, we think that most likely it is a AWS configuration issue.
Affected services